php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78597 MySQL Feature Comparison update
Submitted: 2019-09-25 21:27 UTC Modified: 2019-09-25 22:30 UTC
From: Mike+PHP at HiMikeB dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Mike+PHP at HiMikeB dot com
New email:
PHP Version: OS:

 

 [2019-09-25 21:27 UTC] Mike+PHP at HiMikeB dot com
Description:
------------
---
From manual page: https://php.net/mysqlinfo.api.choosing
---

The table indicates mysqli does not support prepared statements.
Just trying to reconcile with this link, and is it still true or am I misunderstanding something?
https://www.php.net/manual/en/mysqli-stmt.bind-param.php

"Binds variables to a prepared statement as parameters"

What type of client-side prepared statement does mysqli not support?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-25 22:30 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-09-25 22:30 UTC] requinix@php.net
> The table indicates mysqli does not support prepared statements.
*Client-side* statements.

Client-side statements are what PDO's emulated prepares are: an API that makes it look to the developer like they're working with prepared statements, with placeholders and bindings and all that, except what actually happens internally is that it builds the query as a string and sends it to the server as a normal (un-prepared) query.

And mysqli doesn't do that. It doesn't have a way to toggle between whether the statement is prepared on the server or "prepared" on the client. It only does the regular server-side prepared statements. Which is totally okay.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 03:03:35 2021 UTC