php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78554 tokenzier changed behavior
Submitted: 2019-09-17 15:18 UTC Modified: 2019-09-17 15:21 UTC
From: bugreports at gmail dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 7.4Git-2019-09-17 (Git) OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugreports at gmail dot com
New email:
PHP Version: OS:

 

 [2019-09-17 15:18 UTC] bugreports at gmail dot com
Description:
------------
check failed in autotests/custom/code-coverage.php on line 103

Test script:
---------------
/** tokenizer */
if(function_exists('token_get_all') === TRUE)
{
 if(base64_encode(serialize(token_get_all('<?php echo; ?>'))) !== 'YTo1OntpOjA7YTozOntpOjA7aTozNzk7aToxO3M6NjoiPD9waHAgIjtpOjI7aToxO31pOjE7YTozOntpOjA7aTozMjg7aToxO3M6NDoiZWNobyI7aToyO2k6MTt9aToyO3M6MToiOyI7aTozO2E6Mzp7aTowO2k6MzgyO2k6MTtzOjE6IiAiO2k6MjtpOjE7fWk6NDthOjM6e2k6MDtpOjM4MTtpOjE7czoyOiI/PiI7aToyO2k6MTt9fQ==')
 {
  trigger_error('check failed');
  $exit_code = 1;
 }
}


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-17 15:21 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2019-09-17 15:21 UTC] nikic@php.net
The output is the same, only token IDs changed. Token IDs are not stable between PHP versions.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 11:03:35 2022 UTC