|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78552 Openssl extra warnings
Submitted: 2019-09-16 19:27 UTC Modified: 2020-06-28 04:22 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: No Feedback Package: Testing related
PHP Version: 7.4.0RC1 OS: Windows Server 2012 R2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
9 - 5 = ?
Subscribe to this entry?

 [2019-09-16 19:27 UTC] v-altruo at microsoft dot com
Test fails for both x64/x86 and TS/NTS builds regardless of opcache on/off.
These also fail for 7.2.23RC1. 

There are also other tests that have a similar test failure where there is an extra line of output that seems to make the tests fail. 

Failed test locations: 

Expected result:
resource(%d) of type (stream)

Actual result:
resource(9) of type (stream)
PHP Warning:  stream_socket_accept(): SSL: An established connection was aborted by the software in your host machine.
 in .\ext\openssl\tests\ : eval()'d code on line 11


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-17 07:51 UTC]
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2019-09-17 07:51 UTC]
For me, these four tests are passing.  Did you run them in
parallel (they're not supposed to)?
 [2019-09-17 18:04 UTC] v-altruo at microsoft dot com
-Status: Feedback +Status: Assigned
 [2019-09-17 18:04 UTC] v-altruo at microsoft dot com
Just got a new test pack and tried again for 7.2.23RC1 one by one to be sure and none of them passed. 

I initially thought it might have been some setup error on my part with openssl, but for 7.3.10RC1 all these tests pass.
 [2019-11-11 23:07 UTC] v-altruo at microsoft dot com
I recently tested this on 7.2.25RC1 and the test still fails. I tried re-downloading the test pack and then running the test individually to make sure, and it fails. However, sometimes I had to run the test more than once test before it was marked as "FAIL". However, every time after the first time it was marked "FAIL", it would always fail.
 [2020-06-16 16:08 UTC]
-Status: Assigned +Status: Feedback
 [2020-06-16 16:08 UTC]
I still have not been able to reproduce the reported test
failures.  Without further input, I won't be able to do anything
here.  So, if anybody experiences this issue, please provide
further information.
 [2020-06-28 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jul 05 09:05:45 2022 UTC