php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78541 DateInterval documentation has not been updated
Submitted: 2019-09-15 00:41 UTC Modified: 2019-09-15 06:11 UTC
From: danielklein at airpost dot net Assigned:
Status: Duplicate Package: Documentation problem
PHP Version: 7.3.9 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: danielklein at airpost dot net
New email:
PHP Version: OS:

 

 [2019-09-15 00:41 UTC] danielklein at airpost dot net
Description:
------------
---
From manual page: https://php.net/class.dateinterval
---

There are now more public properties, but none of these new ones have been documented yet.

Please add these new properties and explain how to use them.

Expected result:
----------------
/* Properties */
public integer $y ;
public integer $m ;
public integer $d ;
public integer $h ;
public integer $i ;
public integer $s ;
public float $f ;
public integer $weekday ;
public integer $weekday_behavior ;
public integer $first_last_day_of ;
public integer $invert ;
public mixed $days ;
public integer $special_type ;
public integer $special_amount ;
public integer $have_weekday_relative ;
public integer $have_special_relative ;


Actual result:
--------------
/* Properties */
public integer $y ;
public integer $m ;
public integer $d ;
public integer $h ;
public integer $i ;
public integer $s ;
public float $f ;
public integer $invert ;
public mixed $days ;


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-15 06:11 UTC] kalle@php.net
-Status: Open +Status: Duplicate
 [2019-09-15 06:11 UTC] kalle@php.net
Duplicate of bug #78540
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 06:01:26 2020 UTC