php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78533 PECL HTTP Documentation Page not found
Submitted: 2019-09-13 12:37 UTC Modified: 2019-09-13 12:52 UTC
From: radon8472 at radon-software dot net Assigned: cmb (profile)
Status: Not a bug Package: Website problem
PHP Version: Irrelevant OS: irelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: radon8472 at radon-software dot net
New email:
PHP Version: OS:

 

 [2019-09-13 12:37 UTC] radon8472 at radon-software dot net
Description:
------------
I tried to find the documentation for the Documentation of HttpRequest From PECL HTTP. (I would prefer to see it in english or german)

Expected result:
----------------
I Expected to find the Documentation page, cause I am sure it existed once.
And I expected to find it via the search too.
My prefered languages are english and german.

Actual result:
--------------
Actuall Result:

The search was not able to find it.
I was searching a lot more with following links on the page an asking google...
The page was not found in my language.

After some time, I found "http://docs.php.net/manual/da/class.httprequest.php"
What is the desired documentation but in a other language.
I tried to switch the language to german, and english.
Both resulted in a 404 not found error telling the message "The manual page you are looking for (http://docs.php.net/manual/de/book.http.php) is not available on this server right now. Please check back later, or if the problem persists, contact the webmasters."

I assume that something is wrong with the Webserver Config or the database behind it, that this page can no longer be found for any language exept the langcode "da".

On the links:

https://web.archive.org/web/2016*/http://php.net/manual/de/book.http.php
https://web.archive.org/web/20160121041620/http://php.net/manual/de/book.http.php

You can see that the page was last time discovered in german language on 2016-01-21 on 04:16:20.

After that time something change that the page was delivered as 404 Error.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-09-13 12:52 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-09-13 12:52 UTC] cmb@php.net
The documentation about PECL/http in the php.net manual was about
version 1 only.  The documentation of recent versions can be found
at <https://mdref.m6w6.name/http>.  You can find this by going to
the PECL package page[1] and following the [View Documentation]
link.

[1] <https://pecl.php.net/package/pecl_http>
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jun 30 01:03:51 2022 UTC