php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78458 extension_dir="./ext" in php.ini is not working
Submitted: 2019-08-26 14:26 UTC Modified: 2019-08-26 14:36 UTC
From: billy78 at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 7.2.21 OS: Windows 7 SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: billy78 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-08-26 14:26 UTC] billy78 at gmail dot com
Description:
------------
I have PHP v7.2.21 installed as Apache module (php7apache2_4.dll). Apache is installed in C:\Apache24 and PHP is installed in C:\Apache24\php. I use Windows 7 SP1.
I cannot use current directory or relative directory in php.ini for extension_dir
This also occurs with v7.1.31 and v7.3.8
If I use an absolute path, it works.

Test script:
---------------
extension_dir = "./ext"
extension=pdo_sqlite
extension=sqlite3

or

extension_dir = "ext"
extension=pdo_sqlite
extension=sqlite3

Expected result:
----------------
sqlite module is loaded.

Actual result:
--------------
sqlite module is not loaded.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-08-26 14:36 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-08-26 14:36 UTC] requinix@php.net
extension_dir is relative to where PHP is executing from. When running as an Apache module, that might be the Apache directory. Or it might not be.

Use an absolute path.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 22:01:28 2024 UTC