php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78408 Floating point rounding error
Submitted: 2019-08-13 08:32 UTC Modified: 2019-08-13 08:35 UTC
From: djurredenboer at gmail dot com Assigned:
Status: Not a bug Package: Math related
PHP Version: 7.3.8 OS: Linux and Mac
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: djurredenboer at gmail dot com
New email:
PHP Version: OS:

 

 [2019-08-13 08:32 UTC] djurredenboer at gmail dot com
Description:
------------
If you add up 0.30 and 0.15 it and then cast to integer it will end up in 44 instead of 45

Test script:
---------------
<?php
    
$test = 0.30 + 0.15;    
$test2 = ((int)(100 * $test));

echo $test2;

Expected result:
----------------
45

Actual result:
--------------
44

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-08-13 08:35 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-08-13 08:35 UTC] requinix@php.net
Floating point values have a limited precision. Hence a value might
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 24 12:01:25 2020 UTC