php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78193 PHP 7.2/7.3 php_oauth.dll missing
Submitted: 2019-06-21 16:25 UTC Modified: 2019-06-23 18:19 UTC
From: shaun at nookstar dot com Assigned:
Status: Verified Package: oauth (PECL)
PHP Version: 7.3.6 OS: windows 2016
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shaun at nookstar dot com
New email:
PHP Version: OS:

 

 [2019-06-21 16:25 UTC] shaun at nookstar dot com
Description:
------------
Downloaded correct version of NTS oauth 2.0.3 x86 and x64 and tested install with php-7.3.6-nts-Win32-VC15-x64 and for php-7.2.0-nts-Win32-VC15-x86 respectively.

I always get the same outcome in my log files. 

[21-Jun-2019 16:19:17 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'php_oauth.dll' (tried: C:\Program Files\php-7.3.6-nts-Win32-VC15-x64\ext\php_oauth.dll (The specified module could not be found.), C:\Program Files\php-7.3.6-nts-Win32-VC15-x64\ext\php_php_oauth.dll.dll (The specified module could not be found.)) in Unknown on line 0

I'm running windows 2016 with IIS.

Expected result:
----------------
The extension should load with no issues. 

Actual result:
--------------
Extension does not load 

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-22 07:34 UTC] cmb@php.net
> Downloaded correct version of NTS oauth 2.0.3 x86 and x64 and
> tested install with php-7.3.6-nts-Win32-VC15-x64 and for
> php-7.2.0-nts-Win32-VC15-x86 respectively.

From where did you download a PHP 7.2 or 7.3 compatible oauth
2.0.3?  The respective download page on PECL[1] does not offer
these.  As the build logs[2] point out, and config.w32[3]
confirms, oauth is not ready for OpenSSL 1.1 yet.

[1] <https://pecl.php.net/package/oauth/2.0.3/windows>
[2] <https://windows.php.net/downloads/pecl/releases/oauth/2.0.3/logs/>
[3] <http://git.php.net/?p=pecl/web_services/oauth.git;a=blob;f=config.w32;h=b18bdbc196f5f2c36b9687e81964ad6a6bb34e40;hb=HEAD>
 [2019-06-23 00:57 UTC] shaun at nookstar dot com
I downloaded oauth extension for windows here:
https://pecl.php.net/package/oauth
or:
https://pecl.php.net/package/oauth/2.0.3


I downloaded php VC15 x64 Non Thread Safe (2019-May-29 15:24:20)here:
https://windows.php.net/download/
 [2019-06-23 14:09 UTC] cmb@php.net
-Summary: Can not load php_oauth.dll extension +Summary: PHP 7.2/7.3 php_oauth.dll missing
 [2019-06-23 14:09 UTC] cmb@php.net
@shaun, you always need the correct PECL package for any PHP
version.  There are no PHP 7.3 packages, though.
 [2019-06-23 14:09 UTC] cmb@php.net
-Status: Open +Status: Verified
 [2019-06-23 14:10 UTC] cmb@php.net
The following pull request has been associated:

Patch Name: Fix configure for recent cURL versions
On GitHub:  https://github.com/php/pecl-web_services-oauth/pull/6
Patch:      https://github.com/php/pecl-web_services-oauth/pull/6.patch
 [2019-06-23 18:19 UTC] shaun at nookstar dot com
Would you know if there is a time frame I can expect Oauth to be compatible with PHP 7.3 windows?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 08:01:25 2020 UTC