php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78153 $_SERVER['REQUEST_METHOD'] become redirect when form field contains ($_GET)
Submitted: 2019-06-12 22:29 UTC Modified: 2019-06-13 00:22 UTC
From: salamj at gmail dot com Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 7.3.6 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: salamj at gmail dot com
New email:
PHP Version: OS:

 

 [2019-06-12 22:29 UTC] salamj at gmail dot com
Description:
------------
When form with POST method contains text field and fill it with $_GET or $_SESSION , $_POST, ...
the page in action redirect to 403 page error:


Test script:
---------------
<form method="post" action="<?php $_SERVER['PHP_SELF'] ?>">
   <input type="text" name="something">
   <input type="submit" name="send" value="send">
</form>

<?php

$method = $_SERVER['REQUEST_METHOD'];
echo $method;



Expected result:
----------------
POST

Actual result:
--------------
Forbidden

You don't have permission to access /req.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-13 00:22 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-06-13 00:22 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 20:03:38 2021 UTC