php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #78123 Documentation problem str_replace
Submitted: 2019-06-07 13:45 UTC Modified: 2019-06-07 13:48 UTC
From: dacarter at uh dot edu Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dacarter at uh dot edu
New email:
PHP Version: OS:

 

 [2019-06-07 13:45 UTC] dacarter at uh dot edu
Description:
------------
---
From manual page: https://php.net/function.str-replace
---



If you don't need fancy replacing rules (like regular expressions), ...


SHOULD SAY:

If you need fancy replacing rules (like regular expressions), ...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-07 13:48 UTC] sjon@php.net
-Status: Open +Status: Not a bug
 [2019-06-07 13:48 UTC] sjon@php.net
I think you misread that sentence. It reads "If you don't need fancy replacing rules (like regular expressions), you should always use this function instead of preg_replace(). "

so that's correct
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 09:01:23 2020 UTC