php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78122 preg_split returns false since PHP 7.3.5 instead of array
Submitted: 2019-06-06 15:19 UTC Modified: 2019-06-06 15:29 UTC
From: nicolas dot grekas+php at gmail dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 7.3.6 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nicolas dot grekas+php at gmail dot com
New email:
PHP Version: OS:

 

 [2019-06-06 15:19 UTC] nicolas dot grekas+php at gmail dot com
Description:
------------
On 7.3.5 and 7.3.6

Test script:
---------------
var_export(preg_split('//iu', chr(226).'foo'));

Expected result:
----------------
    array (
      0 => '�foo',
    )

Actual result:
--------------
    false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-06 15:29 UTC] nikic@php.net
-Status: Open +Status: Not a bug
 [2019-06-06 15:29 UTC] nikic@php.net
This is an intentional change due to bug #76127. preg_split() was silently ignoring errors, contrary to the documented contract and all other preg_* functions.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 13:05:43 2022 UTC