php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78119 server not running error
Submitted: 2019-06-05 21:04 UTC Modified: 2019-07-11 11:04 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: Duplicate Package: Testing related
PHP Version: 7.3.6 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: v-altruo at microsoft dot com
New email:
PHP Version: OS:

 

 [2019-06-05 21:04 UTC] v-altruo at microsoft dot com
Description:
------------
Test fails only for TS builds with opcache enabled. 

Test file location: ext\opcache\tests\issue0115.phpt

Expected result:
----------------
Hello from Index 1.
Hello World 1!
Hello from Index 2.
Hello World 2!

Actual result:
--------------
Server is not running

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-05 21:10 UTC] v-altruo at microsoft dot com
A similar error occurs for 'ext\opcache\tests\issue0149.phpt' with the same settings mentioned.
 [2019-06-25 18:48 UTC] v-altruo at microsoft dot com
Similar error occurs for ext\opcache\tests\bug78106.phpt with php-7.3.7RC3. 

Error occurs only for TS builds regardless opcache enabled/disabled.
 [2019-06-28 14:50 UTC] cmb@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: cmb
 [2019-06-28 14:50 UTC] cmb@php.net
Thanks!  I can confirm the test failure.  The exit code of the
server process hints at an access violation, which has to be
investigated.

By the way, the code in php_cli_server.inc, which checks that the
server is actually running, makes not much sense.  The for loop is
supposed to be executed multiple times, but if the server process
is not running during the first pass, the code breaks out of the
loop.  Also it makes not much sense to call fsockopen() before
checking the $status.  It likely makes sense to overhaul this code
similar to commit d6480fa[1].

[1] <http://git.php.net/?p=php-src.git;a=commit;h=d6480fa231831feece7403a640b6037c11eec317>
 [2019-07-10 22:07 UTC] v-altruo at microsoft dot com
Similar error occurs for 7.3.7 for the following test: 

ext\opcache\tests\bug78106.phpt

Again, only for all TS builds regardless of opcache on/off.
 [2019-07-11 11:04 UTC] cmb@php.net
-Status: Verified +Status: Duplicate
 [2019-07-11 11:04 UTC] cmb@php.net
Thanks for the ping!

Some further debugging shows that there is indeed a segfault (aka.
access violation) in the CLI server, which is actually caused by
bug #78212, so I'm closing this ticket as duplicate.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 03:01:24 2020 UTC