php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78116 phar failed warning
Submitted: 2019-06-05 19:04 UTC Modified: 2019-06-12 19:20 UTC
From: v-altruo at microsoft dot com Assigned: cmb (profile)
Status: Not a bug Package: Testing related
PHP Version: 7.2.19 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: v-altruo at microsoft dot com
New email:
PHP Version: OS:

 

 [2019-06-05 19:04 UTC] v-altruo at microsoft dot com
Description:
------------
Fails across all builds (NTS/TS) regardless of opcache on/off. 

Test file location: ext\phar\tests\frontcontroller19.phpt

Expected result:
----------------
Fatal error: Uncaught PharException: Too many values passed to Phar::mungServer(), expecting an array of any of these strings: PHP_SELF, REQUEST_URI, SCRIPT_FILENAME, SCRIPT_NAME in %sfrontcontroller19.php:2
Stack trace:
#0 %sfrontcontroller19.php(2): Phar::mungServer(Array)
#1 {main}
  thrown in %sfrontcontroller19.php on line 2

Actual result:
--------------
Warning: include(phar://C:\..\php-test-pack-7.2.19\ext\phar\tests\frontcontroller19.php/oops): failed to open stream: phar error: "oops" is not a file in phar "C:/../php-test-pack-7.2.19/ext/phar/tests/frontcontroller19.php" in C:\..\php-test-pack-7.2.19\ext\phar\tests\frontcontroller19.php on line 9

Warning: include(): Failed opening 'phar://C:\..\php-test-pack-7.2.19\ext\phar\tests\frontcontroller19.php/oops' for inclusion (include_path='phar://C:\..\php-test-pack-7.2.19\ext\phar\tests\frontcontroller19.php;.;C:\php\pear') in C:\..\php-test-pack-7.2.19\ext\phar\tests\frontcontroller19.php on line 9

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-12 14:11 UTC] cmb@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: cmb
 [2019-06-12 14:11 UTC] cmb@php.net
This looks again like a parallel testing issue.  Can you reproduce
if you only run this test?
 [2019-06-12 18:47 UTC] v-altruo at microsoft dot com
-Status: Feedback +Status: Assigned
 [2019-06-12 18:47 UTC] v-altruo at microsoft dot com
You are right, it is a parallel testing issue. I tested it with a new test pack and tested it by itself. It passed without any problems.
 [2019-06-12 19:20 UTC] cmb@php.net
-Status: Assigned +Status: Not a bug
 [2019-06-12 19:20 UTC] cmb@php.net
Okay, so closing this as well.  I've already filed a respective
issue against PFTT2[1].

[1] <https://github.com/php/pftt2/issues/42>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC