php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #78096 PHP reads the wrong libpq file
Submitted: 2019-06-02 03:00 UTC Modified: 2019-06-02 09:30 UTC
From: marcelo at sisflora dot com dot br Assigned: cmb (profile)
Status: Not a bug Package: PostgreSQL related
PHP Version: 7.3.6 OS: Redhat CentOS 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marcelo at sisflora dot com dot br
New email:
PHP Version: OS:

 

 [2019-06-02 03:00 UTC] marcelo at sisflora dot com dot br
Description:
------------
I’m configuring a virtual machine in Google Cloud Platform, accord below.
Virtual Machine: machine type: g1-small (1 vCPU, 1.7 GB memory); zone: us-central1-c; firewalls: Allow HTTP trafficAllow HTTPS traffic.
Operational System: CentOS Linux release 7.6.1810 (Core)
Web server: Apache/2.4.6 (CentOS);
PHP: PHP Version 7.3.6;
Database: PostgreSQL 9.6.13 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-36), 64-bit.
Install PostgreSQL extensions
[gsuite@flora-vm ~]$ sudo yum install php-pgsql
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile 
* base: mirror.cogentco.com 
* epel: mirror.steadfastnet.com 
* extras: mirror.cogentco.com 
* remi-php70: mirror.team-cymru.com 
* remi-php73: mirror.team-cymru.com 
* remi-safe: mirror.team-cymru.com 
* updates: mirror.cogentco.com
Package php-pgsql-7.3.6-3.el7.remi.x86_64 already installed and latest version.
Nothing to do

Set up:
vi /etc/php.d/20-pgsql.ini 
; Enable pgsql extension module
extension=pgsql

vi /etc/php.d/30-pdo_pqsql.ini
; Enable pdo_pgsql extension module
extension=pdo_pgsql

Script to test php connection with database
<?php
//  Configure DB Parameters
$host = "sisflora.com.br";
$dbname = "sisflora";
$dbuser = "postgres";
$userpass = "********";
$con = pg_connect("host=$host dbname=$dbname user=$dbuser password=$userpass");
if (!$con) {
        die('Could not connect');
}
else {
        echo ("Connected to local DB");
}
?>
Running this script return
	Could not connect
Verifying the return on the phpinfo() function find this:
pdo_pgsql: 
PostgreSQL(libpq) version: 9.2.24
pgsql: 
PostgreSQL(libpq) version: 9.2.24 
PostgreSQL(libpq) version: PostgreSQL 9.2.24 on x86_64-redhat-linux-gnu, compiled by gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-28), 64-bit
The sisflora database in PostgreSQL 9.6 it work normally when access from by the psql or pgAdmin4.
My question is, how to configure PHP 7.3.3 to read PostgreSQL 9.6 correctly, considering that the PHP connection recognized PostgreSQL 9.2? 


Test script:
---------------
<?php
//  Configure DB Parameters
$host = "sisflora.com.br";
$dbname = "sisflora";
$dbuser = "postgres";
$userpass = "********";
$con = pg_connect("host=$host dbname=$dbname user=$dbuser password=$userpass");
if (!$con) {
        die('Could not connect');
}
else {
        echo ("Connected to DB");
}
?>

Expected result:
----------------
Connected to DB

Actual result:
--------------
Could not connect

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-02 09:30 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-06-02 09:30 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The libpq version reported by phpinfo is the one the extension has
been compiled against.  If it is not compatible with the actual
server, you need a more up-to-date extension.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 18 06:01:23 2021 UTC