php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78051 Disabling crypto on a crypto-enabled stream socket succeeds silently
Submitted: 2019-05-22 18:00 UTC Modified: 2019-12-01 04:22 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: info at charuru dot moe Assigned: bukka (profile)
Status: No Feedback Package: OpenSSL related
PHP Version: Irrelevant OS: Windows 7 Ultimate x64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
36 - 15 = ?
Subscribe to this entry?

 
 [2019-05-22 18:00 UTC] info at charuru dot moe
Description:
------------
When you try to disable encryption on a stream socket (with encryption enabled), the operation succeeds, however PHP reports this as failure. Both the server and client are able to read and write successfully after disabling encryption.

Test script:
---------------
server.php: https://hastebin.com/zuwamexero.xml
client.php: https://hastebin.com/idadesujal.xml


Expected result:
----------------
server:
string(17) "Hello unencrypted"
bool(true)
string(15) "Hello encrypted"
bool(true)
string(17) "Hello unencrypted"

client:
int(17)
bool(true)
int(15)
bool(true)
int(17)

Actual result:
--------------
server:
string(17) "Hello unencrypted"
bool(true)
string(15) "Hello encrypted"
bool(false)
string(17) "Hello unencrypted"

client:
int(17)
bool(true)
int(15)
bool(false)
int(17)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-05-26 16:38 UTC] info at charuru dot moe
-PHP Version: 7.2.18 +PHP Version: Irrelevant
 [2019-05-26 16:38 UTC] info at charuru dot moe
This bug exists across all maintained versions. 7.2.18 is just the one I tested locally. The others were tested on Travis CI.
 [2019-11-17 18:26 UTC] bukka@php.net
-Status: Open +Status: Feedback -Assigned To: +Assigned To: bukka
 [2019-11-17 18:26 UTC] bukka@php.net
I don't see anything when opening the links - I guess it probably expired. Can you paste it here?
 [2019-12-01 04:22 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue May 18 01:01:25 2021 UTC