php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #78022 Unable to install php7.3-ldap
Submitted: 2019-05-16 15:05 UTC Modified: 2019-05-16 17:49 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ramesh135030 at gmail dot com Assigned:
Status: Not a bug Package: LDAP related
PHP Version: 7.3.5 OS: Debian 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ramesh135030 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-05-16 15:05 UTC] ramesh135030 at gmail dot com
Description:
------------
PHP 7.3.5 (cli) (built: May  8 2019 02:40:53) ( NTS )                        
Copyright (c) 1997-2018 The PHP Group                                        
Zend Engine v3.3.5, Copyright (c) 1998-2018 Zend Technologies                
    with Zend OPcache v7.3.5, Copyright (c) 1999-2018, by Zend Technologies  

root@90922e40286a:/usr/local/etc/php/conf.d# apt install php-ldap                                     
Reading package lists... Done                                                                         
Building dependency tree                                                                              
Reading state information... Done                                                                     
Package php-ldap is a virtual package provided by:                                                    
  php7.3-ldap 7.3.5-1+0~20190503093827.38+stretch~1.gbp60a41b [Not candidate version]                 
  php7.2-ldap 7.2.18-1+0~20190503103213.21+stretch~1.gbp101320 [Not candidate version]                
  php7.1-ldap 7.1.29-1+0~20190503101539.18+stretch~1.gbp946c98 [Not candidate version]                
  php7.0-ldap 7.0.33-7+0~20190503101027.13+stretch~1.gbp26f991 [Not candidate version]                
  php5.6-ldap 5.6.40-7+0~20190503101815.14+stretch~1.gbp1a44f9 [Not candidate version]                
  php7.3-ldap 7.3.4-2 [Not candidate version]                                                         
  php7.0-ldap 7.0.33-0+deb9u3 [Not candidate version]                                                 
                                                                                                      
E: Package 'php-ldap' has no installation candidate                                                   
root@90922e40286a:/usr/local/etc/php/conf.d# apt install php7.3-ldap                                  
Reading package lists... Done                                                                         
Building dependency tree                                                                              
Reading state information... Done                                                                     
Package php7.3-ldap is not available, but is referred to by another package.                          
This may mean that the package is missing, has been obsoleted, or                                     
is only available from another source                                                                 
                                                                                                      
E: Package 'php7.3-ldap' has no installation candidate                                                
root@90922e40286a:/usr/local/etc/php/conf.d# php -m                                                   
[PHP Modules]                                                                                         
Core                                                                                                  
ctype                                                                                                 
curl                                                                                                  
date                                                                                                  
dom                                                                                                   
fileinfo                                                                                              
filter                                                                                                
ftp                                                                                                   
gd                                                                                                    
hash                                                                                                  
iconv                                                                                                 
json                                                                                                  
libxml                                                                                                
mbstring                                                                                              
mysqli                                                                                                
mysqlnd                                                                                               
openssl                                                                                               
pcre                                                                                                  
PDO                                                                                                   
pdo_sqlite                                                                                            
Phar                                                                                                  
posix                                                                                                 
readline                                                                                              
Reflection                                                                                            
session                                                                                               
SimpleXML                                                                                             
sodium                                                                                                
SPL                                                                                                   
sqlite3                                                                                               
standard                                                                                              
tokenizer                                                                                             
xml                                                                                                   
xmlreader                                                                                             
xmlwriter                                                                                             
Zend OPcache                                                                                          
zip                                                                                                   
zlib                                                                                                  
                                                                                                      
[Zend Modules]                                                                                        
Zend OPcache                                                                                          
                                                                                                      

Expected result:
----------------
php7.3-ldap installed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-05-16 15:06 UTC] ramesh135030 at gmail dot com
blocking, please help in resolving.
 [2019-05-16 15:09 UTC] spam2 at rhsoft dot net
this is a distribution packaging problem and has nothing to do with php upstream
 [2019-05-16 17:49 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-05-16 17:49 UTC] requinix@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 19:01:23 2021 UTC