|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7798 httpd doesn't repond to GET requests.
Submitted: 2000-11-13 22:10 UTC Modified: 2000-12-07 09:13 UTC
From: Mike at another-world dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.3pl1 OS: RedHat Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
23 + 29 = ?
Subscribe to this entry?

 [2000-11-13 22:10 UTC] Mike at another-world dot com
The Apache webserver no longer reponds to GET commands at telnet connections.
This has disabled 100% of the webserver, not just PHP pages.
It happens ALL THE TIME. See for yourself:


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-13 23:12 UTC] Mike at another-world dot com
Well, if you try it now it WILL come in... Only because I disabled all PHP references in the Apache httpd.conf file...
 [2000-11-20 01:53 UTC]
What version of Apache? What is your compile string for php look like? Have you tested any other versions? 

 [2000-11-20 01:54 UTC]
What version of Apache? What is your compile string for php look like? Have you tested any other versions? 

 [2000-11-20 07:06 UTC] Mike at another-world dot com
Apache version came with RH Linux 7.
Server version: Apache/1.3.12 (Unix)  (Red Hat/Linux)
Server build:   Aug 23 2000 15:44:50
 [2000-12-04 09:32 UTC]
1. Did you compile PHP from sources?
2. What is the configure line for PHP? Shown with phpinfo()
3. Are there any error messages in Apache logs?
4. Have you tried compling Apache from sources?

 [2000-12-04 15:45 UTC] Mike at another-world dot com
I compiled the PHP from sources. I did not compile Apache from sources. I do not even know how to use PHP (was planning on using premade PHP stuff) so function names are quite useless to me.
 [2000-12-05 07:44 UTC]
Could you please add the configure line you have used
to configure PHP into this bug report?

 [2000-12-05 08:49 UTC] Mike at another-world dot com
 [2000-12-05 19:08 UTC]
Is there some reason why you want to run PHP as CGI binary instead
of running it as DSO ?? 

This should be enough:

# ./configure --with-apxs=/usr/local/apache/bin/apxs

(check that apxs is found on that path)


 [2000-12-05 21:01 UTC] Mike at another-world dot com
Still doesn't work with that option... And I don't have any clue on the technical aspects of Apache...
 [2000-12-07 09:13 UTC]
Have you followed the directions given in the INSTALL
file? Please read that file and do what it says.
And check the error_log for possible messages why
PHP failed.

I'm quite sure there aren't any bugs related to this 
since I and couple of thousand others are running
Apache with PHP (as DSO) without any problems..:)

There is also a mailing list,
on which should ask further questions on how to install
PHP into Apache. 

I will now close this bug report. If you are really
sure that there is bug involved, feel free to reopen this.
But please do include proper information on how the bug
was found and what you did to find it, and information
of how you configured/compiled PHP, etc.

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Mar 26 22:03:37 2023 UTC