php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77908 session.sid_length documentation references removed configuration options
Submitted: 2019-04-16 14:23 UTC Modified: 2019-04-17 10:04 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: chasepeeler at gmail dot com Assigned: cmb (profile)
Status: Closed Package: Session related
PHP Version: 7.1.28 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chasepeeler at gmail dot com
New email:
PHP Version: OS:

 

 [2019-04-16 14:23 UTC] chasepeeler at gmail dot com
Description:
------------
The documentation for session.sid_length (introduced in 7.1) contains:
"Compatibility Note: Use 32 for session.hash_func=0 (MD5) and session.hash_bits_per_character=4, session.hash_func=1 (SHA1) and session.hash_bits_per_character=6. Use 26 for session.hash_func=0 (MD5) and session.hash_bits_per_character=5. Use 22 for session.hash_func=0 (MD5) and session.hash_bits_per_character=6." However, both session.hash_function and session.hash_bits_per_character were removed in 7.1 session.hash_func doesn't even exist.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-04-17 10:03 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&revision=347259
Log: Fix #77908: session.sid_length documentation references removed configuration options
 [2019-04-17 10:04 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-04-17 10:04 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2019-04-17 10:05 UTC] salathe@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=c3ebd7c93144f35f7e45ec89abf0b82a09167a51
Log: Fix #77908: session.sid_length documentation references removed configuration options
 [2020-02-07 06:05 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=d4929a36edfa69000356bd315ebf60f5adc2bf40
Log: Fix #77908: session.sid_length documentation references removed configuration options
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 21:05:51 2022 UTC