php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #77832 aes 256 bit?
Submitted: 2019-04-02 07:05 UTC Modified: 2019-04-02 09:28 UTC
From: 814982736 at qq dot com Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 7.1.27 OS: centos 6.9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 814982736 at qq dot com
New email:
PHP Version: OS:

 

 [2019-04-02 07:05 UTC] 814982736 at qq dot com
Description:
------------
---
From manual page: https://php.net/function.openssl-get-cipher-methods
---
The key size of AES-256-CBC is 256bit size,
but the block size of AES-256-CBC is 128bit size?


Is there any way to use Rijndael-256?





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-04-02 07:29 UTC] spam2 at rhsoft dot net
why would you want to use Rijndael-256?

you end with to everything incomatible data like mcrypt which was funny to get data out and re-encrypt them with something openssl can operate with

https://paragonie.com/blog/2015/05/if-you-re-typing-word-mcrypt-into-your-code-you-re-doing-it-wrong

CTRL+F -> MCRYPT_RIJNDAEL_256
 [2019-04-02 08:19 UTC] 814982736 at qq dot com
After reading this article, i understand the changes of php. Thanks a lot.
 [2019-04-02 08:22 UTC] 814982736 at qq dot com
-Status: Open +Status: Closed
 [2019-04-02 08:22 UTC] 814982736 at qq dot com
solved
 [2019-04-02 09:28 UTC] cmb@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Dec 03 06:05:53 2022 UTC