php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77820 strtotime function errror
Submitted: 2019-03-29 06:50 UTC Modified: 2019-03-29 06:52 UTC
From: yogesh at innovins dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.3.3 OS: Windows 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yogesh at innovins dot com
New email:
PHP Version: OS:

 

 [2019-03-29 06:50 UTC] yogesh at innovins dot com
Description:
------------
---
From manual page: https://php.net/function.strtotime
---
Please check below function. If you use this function on 29th/30th March, The result we are getting is March 2019. Maybe this bug happens only because the Feb month has only 28 days. You should fix this bug.

Test script:
---------------
 echo date("F Y", strtotime("-1 month" )); 

Expected result:
----------------
February 2019


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 16 10:01:23 2021 UTC