php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77770 configure: WARNING: unrecognized options: --enable-gd-native-ttf, --with-mcrypt
Submitted: 2019-03-20 06:31 UTC Modified: 2019-03-20 07:48 UTC
From: mysamraat at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Compile Warning
PHP Version: 7.3.3 OS: CentOS 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mysamraat at gmail dot com
New email:
PHP Version: OS:

 

 [2019-03-20 06:31 UTC] mysamraat at gmail dot com
Description:
------------
I am trying to compile php7.3.3 from source. 

When executing the below command 
./configure --prefix=/usr/local/php7.3.3 --with-config-file-path=/usr/local/php7.3.3/etc --with-config-file-scan-dir=/usr/local/php7.3.3/etc/conf.d --enable-bcmath --with-bz2 --with-curl --enable-filter --enable-fpm --with-gd --enable-gd-native-ttf --with-freetype-dir --with-jpeg-dir --with-png-dir --with-mcrypt --enable-intl --enable-mbstring --enable-mysqlnd --with-mysql-sock=/var/lib/mysql/mysql.sock --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-pdo-sqlite --disable-phpdbg --disable-phpdbg-webhelper --enable-opcache --with-openssl --enable-simplexml --with-sqlite3 --enable-xmlreader --enable-xmlwriter --enable-zip --without-libzip

I get the below error. 
configure: WARNING: unrecognized options: --enable-gd-native-ttf, --with-mcrypt

How to get these recognized?
What are the steps?

Actual result:
--------------
configure: WARNING: unrecognized options: --enable-gd-native-ttf, --with-mcrypt

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-20 07:21 UTC] spam2 at rhsoft dot net
why don't you just basically inform yourself (read release notes for example) instead write random bugreports about configure params so that at least you know mcrypt was deprecated years ago and is now gone?
 [2019-03-20 07:48 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-03-20 07:48 UTC] cmb@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

See <http://php.net/manual/en/mcrypt.installation.php>
and <http://php.net/manual/en/image.installation.php>.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 07:01:24 2020 UTC