|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77749 OpenSSL and alert protocol version
Submitted: 2019-03-15 18:10 UTC Modified: 2019-03-16 10:08 UTC
From: lodashes at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Network Functions
PHP Version: 7.3.3 OS: Windows7, Linux Mint
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: lodashes at gmail dot com
New email:
PHP Version: OS:


 [2019-03-15 18:10 UTC] lodashes at gmail dot com
Hello! I can’t set up working with a secure connection, I cannot determine the cause of the error, maybe I have incorrectly configured the context of the SSL options and I need to specify additional parameters? I tried version 7.2 but the error was the same, I tried to connect to different https servers - failed, connect fails but data exchange fails, I tried to ask a question on the forum - I was told that the reason for the protocol mismatch and it is outdated, I hope YOU help me figure it out, please!

Test script:
$nl = "\r\n";
$headers = (
    "GET / HTTP/1.1" . $nl .
    "Host:". $nl .
    "User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0". $nl .
    "Content-Length: 0". $nl .
    "Connection: close". $nl .
$context = stream_context_create([
   'ssl' => [
       'verify_peer_name' => false,
       'verify_peer' => false
$f = stream_socket_client('ssl://',$a,$b,30,STREAM_CLIENT_CONNECT,$context);
echo stream_get_contents($f);

Expected result:
Valid HTTP Response

Actual result:
WARNING stream_get_contents(): SSL operation failed with code 1. OpenSSL Error messages: error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version on line number 19


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2019-03-16 08:36 UTC] lodashes at gmail dot com
Problem in stream_get_contents, you must use fgets,fgetc,stream_socket_recvfrom to read data, but now i get encrypted data looks like >bÂev��h����$��q*�zhP#, how to get normal data string?
 [2019-03-16 10:08 UTC]
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-03-16 10:08 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 09 07:01:23 2021 UTC