php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77717 Tests can't be run with shared extensions
Submitted: 2019-03-10 13:09 UTC Modified: 2019-06-09 21:18 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: petk@php.net Assigned:
Status: Wont fix Package: *Configuration Issues
PHP Version: 7.2.16 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
14 - 6 = ?
Subscribe to this entry?

 
 [2019-03-10 13:09 UTC] petk@php.net
Description:
------------
When building PHP with shared extensions (common case when packaging it for Linux distributions) several extensions depend on one another and the load order is important in the ini configuration (extension=name.so). If for example the wddx.so extension is loaded before the xml.so, PHP emits some warnings...


This is probably happening with several other extensions that depend on one another as well.

Solution might simply involve making a list of shared extensions in a proper order based on their dependencies (PHP_MODULES in Makefile).


Test script:
---------------
./configure --disable-all --enable-wddx=shared --enable-xml=shared --enable-libxml
make
make test

Expected result:
----------------
Tests executed without warnings about missing extensions.

Actual result:
--------------
PHP Warning:  PHP Startup: Unable to load dynamic library 'wddx.so' (tried: /var/www/app/modules/wddx.so (Error relocating /var/www/app/modules/wddx.so: php_XML_SetCharacterDataHandler: symbol not found), /var/www/app/modules/wddx.so.so (Error loading shared library /var/www/app/modules/wddx.so.so: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'wddx.so' (tried: /var/www/app/modules/wddx.so (Error relocating /var/www/app/modules/wddx.so: php_XML_SetCharacterDataHandler: symbol not found), /var/www/app/modules/wddx.so.so (Error loading shared library /var/www/app/modules/wddx.so.so: No such file or directory)) in Unknown on line 0



Patches

Website you has been hacked by : @rOo7sh3ll.. your security is low... lol.. ???? (last revision 2019-03-12 18:21 UTC by ArayNet007 at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-06-09 21:18 UTC] petk@php.net
-Status: Open +Status: Wont fix
 [2019-06-09 21:18 UTC] petk@php.net
Hello,

Closing this one as Won't fix since according to similar issues out there with one of the extensions - mailparse - there was a decision that this is not meant to be fixed directly in the core... Maybe some cases aren't that important with extensions or something I'm not sure, but fixing this bug is quite related to that approach so meaning this can't be fixed either then...
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 22:01:27 2019 UTC