php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #7768 PHP is crashing -> ldap_mod_add
Submitted: 2000-11-12 14:41 UTC Modified: 2000-11-12 21:05 UTC
From: lars at kneschke dot de Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.0.2 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
1 + 24 = ?
Subscribe to this entry?

 
 [2000-11-12 14:41 UTC] lars at kneschke dot de
$preference["2"] = "true";
ldap_mod_add($ds, $dn, $preference);


This piece of code is crashing php. The problem is the number as key.

'./configure' '--with-openssl' '--with-ldap' '--enable-force-cgi-redirect' '--with-pdflib'  '--with-gettext' '--with-mysql' '--prefix=/opt/php-4.0.2' '--with-imap'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-11-12 21:05 UTC] sniper@php.net
Fixed in CVS.  Thank you for pointing this out!
Now if some key is numeric PHP will fail.

--Jani
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 10:03:51 2022 UTC