php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77675 Floating Value Bug
Submitted: 2019-02-27 14:14 UTC Modified: 2019-02-27 14:31 UTC
From: joni dot ttv at gmx dot de Assigned: cmb (profile)
Status: Not a bug Package: Math related
PHP Version: 7.2.15 OS: Debian, Mac OS
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: joni dot ttv at gmx dot de
New email:
PHP Version: OS:

 

 [2019-02-27 14:14 UTC] joni dot ttv at gmx dot de
Description:
------------
Hello,

there is a problem when adding float values:

If you add 76.50 + 15.96 + 7.54 the result ist 100.00. If you var_dump the sum the result is also 100.00. But when you compare the sum and 100.00 the result is that they are not equal.
If you swap the last two numbers, the sum is correct and also the comparison.

Test script:
---------------
<?php

// Prints 100
var_dump(76.50 + 15.96 + 7.54);

// Prints false (should be true)
var_dump((76.50 + 15.96 + 7.54) == 100.00);

// Prints false (should be true)
var_dump((76.50 + 15.96 + 7.54) == (76.50 + 7.54 + 15.96));

Expected result:
----------------
100.00
true
true

Actual result:
--------------
100.00
false
false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-27 14:31 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-02-27 14:31 UTC] cmb@php.net
Floating point values have a limited precision. Hence a value might 
not have the same string representation after any processing. That also
includes writing a floating point value in your script and directly 
printing it without any mathematical operations.

If you would like to know more about "floats" and what IEEE
754 is, read this:
http://www.floating-point-gui.de/

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 11:01:25 2020 UTC