php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #77650 Release a version of pecl/ssh2 that builds on PHP 7.3
Submitted: 2019-02-22 00:08 UTC Modified: 2019-11-27 09:42 UTC
Votes:22
Avg. Score:4.6 ± 0.6
Reproduced:22 of 22 (100.0%)
Same Version:20 (90.9%)
Same OS:8 (36.4%)
From: ramsey@php.net Assigned: cmb (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: 7.3.2 OS: n/a
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ramsey@php.net
New email:
PHP Version: OS:

 

 [2019-02-22 00:08 UTC] ramsey@php.net
Description:
------------
The latest release of the ssh2 extension (1.1.2, released in 2017) doesn’t build on PHP 7.3, but it looks like there are commits in the master branch that fix this. I’ve confirmed, and I’m able to build the latest state of master (79371dc) on PHP 7.3.

Please release a new version of the extension for PHP 7.3.


Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-04-24 23:07 UTC] goldorakhong at gmail dot com
I've postponed the migration of my dev environment for months after a few attempts because of this,
Thanks to Ramsey, I found the sources that can be compiled for 7.3, just before I give up once again.

P.S., for people looking a solution with a search engine (which I couldn't find myself):

If you're stuck with compiling errors like:

error: invalid operands to binary expression ('zend_string' (aka 'struct _zend_string') and 'int')

or

warning: incompatible pointer types assigning to 'char *' from 'zend_string *' (aka 'struct _zend_string *')

you will be able to install the ssh2.so extension for PHP7.3 using a recent snapshot of the source code that can be found here:
http://git.php.net/?p=pecl/networking/ssh2.git;a=summary
 [2019-05-29 13:48 UTC] dasteph at gmail dot com
I could just reproduce:

docker run php:7.3 bash -c "apt-get update && apt-get -y install libssh2-1-dev && pecl install ssh2-1.1.2"
=> Makefile:196: recipe for target 'ssh2_fopen_wrappers.lo' failed
make: *** [ssh2_fopen_wrappers.lo] Error 1
ERROR: `make' failed
 [2019-07-18 11:58 UTC] thephilosoft at gmail dot com
The following pull request has been associated:

Patch Name: Remove inline from php_ssh2_sftp_attr2ssb
On GitHub:  https://github.com/php/pecl-networking-ssh2/pull/36
Patch:      https://github.com/php/pecl-networking-ssh2/pull/36.patch
 [2019-11-27 09:42 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2019-11-27 09:42 UTC] cmb@php.net
ssh2 1.2 is compatible with PHP 7.3+, so this ticket can be
closed.  Note that the download link does not work currently[1],
and that this is not a stable version[2].

[1] <https://bugs.php.net/78560>
[2] <https://bugs.php.net/77265>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Feb 26 14:01:28 2020 UTC