php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77640 Array Destructuring Reference Assignments
Submitted: 2019-02-19 13:18 UTC Modified: 2019-02-19 18:58 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: qRoc dot Work at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.3.2 OS: OS X/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: qRoc dot Work at gmail dot com
New email:
PHP Version: OS:

 

 [2019-02-19 13:18 UTC] qRoc dot Work at gmail dot com
Description:
------------
Not correct result for last element if use "Array Destructuring Reference Assignments"

Test script:
---------------
<?php
$timeUnits = [[2], [4], [8]];

foreach ($timeUnits as [&$baseCount]) {
    $baseCount += 1;
}

foreach ($timeUnits as [&$baseCount]) { echo $baseCount; } echo PHP_EOL;
foreach ($timeUnits as [$baseCount]) { echo $baseCount; } echo PHP_EOL;
foreach ($timeUnits as [&$baseCount]) { echo $baseCount; } echo PHP_EOL;


Expected result:
----------------
359
359
359

Actual result:
--------------
359
355
355

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-19 18:58 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2019-02-19 18:58 UTC] requinix@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

http://php.net/manual/en/control-structures.foreach.php
Big red warning
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 11:01:26 2021 UTC