php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77634 PDO::quote cannot call static
Submitted: 2019-02-18 13:28 UTC Modified: 2019-02-20 18:16 UTC
From: peter dot mlich at volny dot cz Assigned:
Status: Not a bug Package: PDO related
PHP Version: Irrelevant OS: w10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: peter dot mlich at volny dot cz
New email:
PHP Version: OS:

 

 [2019-02-18 13:28 UTC] peter dot mlich at volny dot cz
Description:
------------
---
From manual page: https://php.net/pdo.quote
---
Function PDO::quote cannot call static? Why?
(php 5.3)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-18 16:35 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Type: Documentation Problem +Type: Bug
 [2019-02-18 16:35 UTC] requinix@php.net
Because how a string is quoted depends on the database driver and possibly the connection.
 [2019-02-20 13:23 UTC] peter dot mlich at volny dot cz
Can i use quote, driver, if i not have sql server?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 24 09:01:30 2024 UTC