php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77595 concurrent processes prevent filesize() from working
Submitted: 2019-02-10 05:43 UTC Modified: 2019-02-10 21:29 UTC
From: Wes dot nospam at example dot org Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 7.2.15 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
27 - 23 = ?
Subscribe to this entry?

 
 [2019-02-10 05:43 UTC] Wes dot nospam at example dot org
Description:
------------
other processes are denied to write the file while it is shared-locked, but attempting to do so prevents filesize() from working

Test script:
---------------
<?php

// create a file of 6 bytes
$path = __DIR__ . "/foo.txt";
file_put_contents($path, "123456");


// (1)
// open that file for read and shared-lock it
$file = fopen($path, "r");
flock($file, LOCK_SH | LOCK_NB);


// (2)
// attempt to write that file concurrently while the lock is active
echo `php -r "file_put_contents('$path', 'baz');"`;
// this step fails as expected -- means the file is still "123456"


// (3)
// attempt to read the file's size
clearstatcache(FALSE, $path);
$fileSize = filesize($path);
// should return 6 bytes but returns 0


// (4)
// this fails as consequence
echo $fileSize . "\n";
echo fread($file, $fileSize);


flock($file, LOCK_UN);
fclose($file);

Expected result:
----------------
should work as if the step (2) was commented out


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-10 21:29 UTC] krakjoe@php.net
-Status: Open +Status: Not a bug
 [2019-02-10 21:29 UTC] krakjoe@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 22:05:52 2022 UTC