php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77568 Urgent : PHP 7.3.1 failed on startup because of intl library
Submitted: 2019-02-05 13:44 UTC Modified: 2019-02-05 21:38 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: fodger1975 at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: *Compile Issues
PHP Version: 7.3.1 OS: Debian stretch
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fodger1975 at gmail dot com
New email:
PHP Version: OS:

 

 [2019-02-05 13:44 UTC] fodger1975 at gmail dot com
Description:
------------
PHP Warning:  PHP Startup: Unable to load dynamic library 'intl' (tried: /usr/lib/php/20180731/intl (/usr/lib/php/20180731/intl: cannot open shared object file: No such file or directory), /usr/lib/php/20180731/intl.so (/usr/lib/php/20180731/intl.so: undefined symbol: spoofchecker_register_constants)) in Unknown on line 0
PHP 7.3.1-2+0~20190204160533.27+stretch~1.gbp1b9ae6 (cli) (built: Feb  4 2019 16:05:33) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.1, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.1-2+0~20190204160533.27+stretch~1.gbp1b9ae6, Copyright (c) 1999-2018, by Zend Technologies

Test script:
---------------
Context :
- Fresh new installation under Debian stretch 9.7
- Apt source : deb https://packages.sury.org/php/ stretch main


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-02-05 13:47 UTC] spam2 at rhsoft dot net
this is a *debian* issue
 [2019-02-05 14:03 UTC] fodger1975 at gmail dot com
Declared also on https://github.com/oerdnj/deb.sury.org/issues/1075
 [2019-02-05 21:38 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: Reproducible crash +Package: *Compile Issues -Assigned To: +Assigned To: cmb
 [2019-02-05 21:38 UTC] cmb@php.net
Indeed, this is a Debian packaging issue.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 20:01:28 2020 UTC