php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77534 7.0
Submitted: 2019-01-28 12:21 UTC Modified: 2019-01-28 14:23 UTC
From: mags at inbox dot ru Assigned: cmb (profile)
Status: Not a bug Package: *Math Functions
PHP Version: 7.3.2RC1 OS: linux debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mags at inbox dot ru
New email:
PHP Version: OS:

 

 [2019-01-28 12:21 UTC] mags at inbox dot ru
Description:
------------
is_numeric("069") = true  ?  ok
$array[123=>"069"];  ok
$array[123=>069];   invalid numeric  literal compilation error!
why?
pls fix or compilator or is_numeric

Test script:
---------------
is_numeric("069") = true  ?  ok
$array[123=>"069"];  ok
$array[123=>069];   invalid numeric  literal compilation error!
why?
pls fix or compilator or is_numeric

Expected result:
----------------
ok
ok 
invalid numeric  literal compilation error!

Actual result:
--------------
ok
ok
ok

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-28 14:23 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2019-01-28 14:23 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon May 17 14:01:24 2021 UTC