php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77527 Solr Extension build fail in last commit 9c0e23
Submitted: 2019-01-27 08:54 UTC Modified: 2019-07-15 23:38 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: tuanbk08vn at gmail dot com Assigned: omars (profile)
Status: Closed Package: solr (PECL)
PHP Version: 7.2.14 OS: CentOs6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
37 + 38 = ?
Subscribe to this entry?

 
 [2019-01-27 08:54 UTC] tuanbk08vn at gmail dot com
Description:
------------
Solr Extension build fail in last commit 9c0e23


-The list of modules that PHP compiled with:
  + Curl 7.19.0
  + LibXml2 2.7.6


Test script:
---------------
/usr/bin/phpize
./configure
make


https://github.com/php/pecl-search_engine-solr 
(commit 9c0e234)

Expected result:
----------------
Build complete

Actual result:
--------------
/mnt/php-7.2.14/ext/solr/src/php7/solr_functions_client.c: In function ‘solr_set_initial_curl_handle_options’:
/mnt/php-7.2.14/ext/solr/src/php7/solr_functions_client.c:88: error: ‘CURLOPT_ACCEPT_ENCODING’ undeclared (first use in this function)
/mnt/php-7.2.14/ext/solr/src/php7/solr_functions_client.c:88: error: (Each undeclared identifier is reported only once
/mnt/php-7.2.14/ext/solr/src/php7/solr_functions_client.c:88: error: for each function it appears in.)

Patches

Add a Patch

Pull Requests

Pull requests:

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-28 03:20 UTC] tuanbk08vn at gmail dot com
For CentOS 6, the latest available version of curl is 7.19.0

'CURLOPT_ACCEPT_ENCODING' was called CURLOPT_ENCODING before curl 7.21.6
(Ref: https://curl.haxx.se/libcurl/c/CURLOPT_ACCEPT_ENCODING.html)
 [2019-01-28 14:31 UTC] cmb@php.net
-Package: Compile Failure +Package: solr
 [2019-03-07 05:52 UTC]
The following pull request has been associated:

Patch Name: Fix #77527: Solr Extension build fail in due to curl CURLOPT_ACCEPT_ENCODING
On GitHub:  https://github.com/php/pecl-search_engine-solr/pull/11
Patch:      https://github.com/php/pecl-search_engine-solr/pull/11.patch
 [2019-03-19 09:57 UTC] omars@php.net
merged to master
 [2019-07-15 23:38 UTC] omars@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: omars
 [2019-07-15 23:38 UTC] omars@php.net
released: 2.5.0
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 00:01:27 2019 UTC