php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77501 listen = 9000 only listens on one interface
Submitted: 2019-01-22 17:23 UTC Modified: 2019-01-22 17:37 UTC
From: laszlo at karolyi dot hu Assigned:
Status: Duplicate Package: FPM related
PHP Version: 7.3.1 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: laszlo at karolyi dot hu
New email:
PHP Version: OS:

 

 [2019-01-22 17:23 UTC] laszlo at karolyi dot hu
Description:
------------
Hey,

I have a FreeBSD box, wanting to jail php-fpm into a jail which has a loopback interface (lo0) with a 127.0.0.x IP, and a bridge0 interface with an actual IPv6 address.

I can't get php to listen on both IPs and interfaces with just specifying listen = 9000

listen = :::9000 will only listen to the IPv6 interface (normal),
listen = 9000 will only bind to the IPV6 interface (NOT normal)
listen = 0.0.0.0:9000 will only listen on lo0, as expected.

There's no middle way. I tried to specify two listen lines in the same section, to no avail.

Please fix this. The only way to get PHP to listen on both interfaces is to define two of the same php-fpm configurations, with the only difference being the listen directive.

Expected result:
----------------
listen = 9000 should bind to ALL interfaces, regardless of what type of IP stack they have.

Actual result:
--------------
defined above.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-22 17:37 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2019-01-22 17:37 UTC] requinix@php.net
Duplicate of bug #77482
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 13:01:27 2019 UTC