php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77293 pecl/mcrypt is not compatible with PHP version 7.3.0
Submitted: 2018-12-13 15:19 UTC Modified: 2019-02-08 05:08 UTC
Votes:12
Avg. Score:4.5 ± 0.8
Reproduced:12 of 12 (100.0%)
Same Version:11 (91.7%)
Same OS:4 (33.3%)
From: krzysztof dot pyrzyk at gmail dot com Assigned: petk (profile)
Status: Closed Package: PECL (PECL)
PHP Version: 7.3.0 OS: Alpine 3.8
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: krzysztof dot pyrzyk at gmail dot com
New email:
PHP Version: OS:

 

 [2018-12-13 15:19 UTC] krzysztof dot pyrzyk at gmail dot com
Description:
------------
I cannot install mcrypt with PHP 7.3 due to a lack of compatibility.
Mcrypt's page says it's compatible with 7.3 though.

Test script:
---------------
// Dockerfile
FROM php:7.3.0-fpm-alpine

RUN pecl install mcrypt-1.0.1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2019-01-02 11:22 UTC] nikic@php.net
Looks like there is a PR for this: https://github.com/php/pecl-encryption-mcrypt/pull/2
 [2019-02-08 05:08 UTC] petk@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: petk
 [2019-02-08 05:08 UTC] petk@php.net
PHP 7.3 compatibility has been resolved via the mcrypt 1.0.2 release.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Oct 18 19:01:28 2019 UTC