php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77271 PHP 7.3: Various info missing from changelog/migration guide
Submitted: 2018-12-09 14:23 UTC Modified: 2018-12-10 15:25 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: bugs dot php dot net_nospam at adviesenzo dot nl Assigned: cmb (profile)
Status: Closed Package: Documentation problem
PHP Version: 7.3.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs dot php dot net_nospam at adviesenzo dot nl
New email:
PHP Version: OS:

 

 [2018-12-09 14:23 UTC] bugs dot php dot net_nospam at adviesenzo dot nl
Description:
------------
I realize you all are probably still working on updating the docs for PHP 7.3, but hopefully this list of findings will help <3

* The changelog for 7.3.0 - github.com/php/php-src/blob/PHP-7.3.0/UPGRADING - is missing a number of changelog entries which are included in the 7.3 changelog - github.com/php/php-src/blob/PHP-7.3/UPGRADING - for changes which *have* been shipped with 7.3.0.

Additionally, the migration guide makes no mention of the following:
* New functions:
    - `net_get_interfaces()` (also missing from UPGRADING, but mentioned in NEWS and php.net/ChangeLog-7.php#7.3.0)
    - `ldap_exop_refresh()` (also missing from UPGRADING, but mentioned in NEWS and php.net/ChangeLog-7.php#7.3.0)
* New constants:
    - `FILTER_SANITIZE_ADD_SLASHES` (mentioned in php.net/manual/en/migration73.other-changes.php#migration73.other-changes.filter, but not on the new constants page)
    - `LDAP_CONTROL_ASSERT`
    - `STREAM_CRYPTO_PROTO_TLSv1_0`
    - `STREAM_CRYPTO_PROTO_TLSv1_1`
    - `STREAM_CRYPTO_PROTO_TLSv1_2`

Other remarks:
* Lightweight Directory Access Protocol: php.net/manual/en/migration73.new-features.php#migration73.new-features.ldap vs the documentation of the `ldap_parse_result()` function php.net/manual/en/function.ldap-parse-result.php
    The way it looks to me, the documentation on the `ldap_parse_result()` function page is wrong. Not the `$serverctrls` parameter, but an `$out` parameter has been added. This is also listed wrong in the `Changelog` section of the page and the parameter is also missing from the `Parameters` documentation for the function.
* Lightweight Directory Access Protocol: php.net/manual/en/migration73.new-features.php#migration73.new-features.ldap vs the documentation of the `ldap_get_option()` function php.net/manual/en/function.ldap-get-option.php and the `ldap_set_option()` function php.net/manual/en/function.ldap-set-option.php
    The way it looks to me, the documentation on the `ldap_get_option()` and the `ldap_set_option()` function pages is missing the `since 7.3` for the `LDAP_OPT_SERVER_CONTROLS` and `LDAP_OPT_CLIENT_CONTROLS` options.
    If those were previously already supported, then the entry (third bullet) in the changelog probably needs improved wording.
* LDAP Constants php.net/manual/en/ldap.constants.php
    Looks like the new constants were added, but without a `since 7.3` mention.
* Continue Targeting Switch issues Warning: The second line of the error message is missing a `//` before it in the code sample in php.net/manual/en/migration73.incompatible.php#migration73.incompatible.core.continue-targeting-switch
* FastCGI Process Manager php.net/manual/en/migration73.new-features.php#migration73.new-features.fpm
    Looks like the new options aren't listed yet on php.net/manual/en/install.fpm.configuration.php
    And just to check my own comprehension: these are just to be used in `php-fpm.conf` ? and cannot be accessed through `ini_get()` or `ini_set()` ?
* Strip-Tags Streaming php.net/manual/en/migration73.deprecated.php#migration73.deprecated.core.strip-tags-streaming
    Looks like the affected functions has not been marked as deprecated yet - php.net/manual/en/function.fgetss.php (and the others).
    Looks like the deprecation of the `string.strip_tags` stream filter has not be annotated yet: php.net/manual/en/filters.string.php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-12-09 14:31 UTC] bugs dot php dot net_nospam at adviesenzo dot nl
One more:
Looks like the `CURL_VERSION_KERBEROS5` and the `CURL_VERSION_UNIX_SOCKETS` constants were already introduced in PHP 7.0.7, so these are, AFAICS, *not* new to PHP 7.3.
 [2018-12-10 15:10 UTC] cmb@php.net
-Status: Open +Status: Verified -Assigned To: +Assigned To: cmb
 [2018-12-10 15:10 UTC] cmb@php.net
> The changelog for 7.3.0 […] is missing a number of changelog
> entries which are included in the 7.3 changelog […] for changes
> which *have* been shipped with 7.3.0.

Sorry, my bad.

> The way it looks to me, the documentation on the
> `ldap_parse_result()` function page is wrong. Not the
> `$serverctrls` parameter, but an `$out` parameter has been added.

Well, the name of the parameter is $serverctrls, and it is passed
by reference, but only used as out parameter (i.e. it does not
matter wich value you pass to the function).

> The way it looks to me, the documentation on the
> `ldap_get_option()` and the `ldap_set_option()` function pages is
> missing the `since 7.3` for the `LDAP_OPT_SERVER_CONTROLS` and
> `LDAP_OPT_CLIENT_CONTROLS` options.

These options have already been supported by these functions
before, but not properly, so the support has been fixed now.  I'm
going to reword the migration guide entry.
 [2018-12-10 15:24 UTC] cmb@php.net
Automatic comment from SVN on behalf of cmb
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=346281
Log: Fix #77271: PHP 7.3: Various info missing from changelog/migration guide
 [2018-12-10 15:25 UTC] cmb@php.net
-Status: Verified +Status: Closed
 [2018-12-10 15:25 UTC] cmb@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2018-12-10 22:52 UTC] bugs dot php dot net_nospam at adviesenzo dot nl
Thanks for your response & for fixing up the docs <3
 [2020-02-07 06:05 UTC] phpdocbot@php.net
Automatic comment on behalf of cmb
Revision: http://git.php.net/?p=doc/en.git;a=commit;h=2a85fbcd7c2e030f18cd88cd515dd602042cd598
Log: Fix #77271: PHP 7.3: Various info missing from changelog/migration guide
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Apr 11 03:01:23 2021 UTC