php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77212 Memory allocation failed : growing buffer on aws server
Submitted: 2018-11-28 13:09 UTC Modified: 2018-11-28 15:18 UTC
From: sujaljhaonly4u at gmail dot com Assigned:
Status: Not a bug Package: SimpleXML related
PHP Version: 5.6.38 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sujaljhaonly4u at gmail dot com
New email:
PHP Version: OS:

 

 [2018-11-28 13:09 UTC] sujaljhaonly4u at gmail dot com
Description:
------------
Hi, i am receiving this message when i am trying to parse the 1.7gb xml file for inserting on aws server.
Memory allocation failed : growing buffer..
please help me out!

Thank You,

Sujal Jha

Test script:
---------------
<?php
include('../product/upload_function_backup.php');
include('../../config/database.php');
include('../../objects/hooks/function.php');
$dir = '../product_feeds/tata cliq';
$file= "tata_cliq_fashion.xml";
$data = file_get_contents($dir.'/'.$file);
$xml=stripslashes($data);
libxml_use_internal_errors(true);
$arr = simplexml_load_string((string)$xml);
foreach( libxml_get_errors() as $error ) {

    print_r($error);
}
print_r($arr);
?>


Expected result:
----------------
SimpleXMLElement Object
(
    [Product] => Array
        (
            [0] => SimpleXMLElement Object
                (
                    [ProductID] => 1065005367
                    [ProductSKU] => A08160
                    [ProductName] => WOMEN'S TRAINING STELLASPORT WOVEN SHORTS
                    [ProductDescription] => Stella McCartney inspired adidas SC Woven shorts for women. It comes with an Elasticated waist with two side pockets, one back zipped pocket and all-over 'Stellasport' branding.
                    [ProductPrice] => 1000.00
                    [ProductPriceCurrency] => INR
                    [WasPrice] => 2499.00
                    [DiscountedPrice] => 0.00
                    [ProductURL] => http://clk.omgt5.com/?AID=1327881&PID=17736&Type=12&r=https://shop.adidas.co.in/%23!product/A08160_scwovenshort
                    [PID] => 17736
                    [MID] => 929898
                    [ProductImageMediumURL] => https://content.adidas.co.in/static/Product-A08160/Women_Training_Shorts_A08160_1.jpg
                    [StockAvailability] => In stock
                    [Brand] => SPORT PERFORMANCE
                    [custom1] => Gender - Female
                    [custom2] => AgeGroup - Adult
                    [CategoryName] => SHORTS (1/4)
                    [CategoryPathAsString] => Root|TEXTILES|SHORTS (1/4)|
                )
)


Patches

add-fronk-support (last revision 2018-11-28 13:15 UTC by sujaljhaonly4u at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-28 14:19 UTC] spam2 at rhsoft dot net
this is a bugtracker and not a support forum!

contact your administrator and make sure you have *at least* twice the memory of stuff you want to proceed available and that there are no resource limits
 [2018-11-28 15:18 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2018-11-28 15:18 UTC] cmb@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 06:03:45 2022 UTC