php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77167 [ZH] missing minus sign
Submitted: 2018-11-16 10:24 UTC Modified: 2018-11-16 15:46 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: 381343736 at qq dot com Assigned: daijie (profile)
Status: Closed Package: Translation problem
PHP Version: 7.2.12 OS: mac os x
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 381343736 at qq dot com
New email:
PHP Version: OS:

 

 [2018-11-16 10:24 UTC] 381343736 at qq dot com
Description:
------------
uri: 
http://php.net/manual/zh/regexp.reference.back-references.php

here:
(foo)(bar)\g{2} 可以匹配 ”foobarfoo”。

should be:
(foo)(bar)\g{-2} 可以匹配 ”foobarfoo”。

(foo)(bar)\g{2} => (foo)(bar)\g{-2}
missing minus sign


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-11-16 13:13 UTC] cmb@php.net
-Summary: missing minus sign +Summary: [ZH] missing minus sign -Status: Open +Status: Verified
 [2018-11-16 15:32 UTC] daijie@php.net
I'll fix it soon.
 [2018-11-16 15:42 UTC] daijie@php.net
Automatic comment from SVN on behalf of daijie
Revision: http://svn.php.net/viewvc/?view=revision&revision=345990
Log: Fix #77167 [ZH] missing minus sign
 [2018-11-16 15:46 UTC] daijie@php.net
-Status: Verified +Status: Closed -Assigned To: +Assigned To: daijie
 [2018-11-16 15:46 UTC] daijie@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC