php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #77039 about `protected` keywords
Submitted: 2018-10-19 07:56 UTC Modified: 2021-02-01 13:21 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: 200847041 at qq dot com Assigned: cmb (profile)
Status: Duplicate Package: Scripting Engine problem
PHP Version: 7.2.11 OS: Ubuntu16
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: 200847041 at qq dot com
New email:
PHP Version: OS:

 

 [2018-10-19 07:56 UTC] 200847041 at qq dot com
Description:
------------
Derived classes of the same base class can access each other's protected method and protected property.

Test script:
---------------
class Base {
protected function foo() {
   echo 'foo';
}
}

class A extends Base {

}

class B extends Base {

public function bar() {
  $a = new A();
  // in fact, it is ok, and will echo foo.
  // but I think it should not access
  $a->foo();
}

}

(new B())->bar();


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2021-02-01 13:21 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: Doc Build problem +Package: Scripting Engine problem -Assigned To: +Assigned To: cmb
 [2021-02-01 13:21 UTC] cmb@php.net
Closing as duplicate of bug #50892.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Feb 28 18:01:23 2021 UTC