php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #77012 PHP doesn't really offer mysql_ anymore
Submitted: 2018-10-15 12:42 UTC Modified: 2018-10-15 12:49 UTC
From: olafvdspek at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 7.3.0RC3 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: olafvdspek at gmail dot com
New email:
PHP Version: OS:

 

 [2018-10-15 12:42 UTC] olafvdspek at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/mysqlinfo.api.choosing
---

>  Below we show the APIs provided by the mysql, mysqli, and PDO extensions.

The mysql extension has been gone since 7.0 IIRC.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-15 12:47 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-10-15 12:47 UTC] cmb@php.net
Presently, the PHP manual is supposed to document PHP ≥ 5.0.0, and
in the following section “Recommended API” it is noted that mysql
is deprecated as of PHP 5.5.0 and removed in PHP 7.
 [2018-10-15 12:49 UTC] olafvdspek at gmail dot com
I know, it's just that "PHP offers three different APIs to connect to MySQL. " is only true for PHP 7, which is indeed explained later on.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 09:01:23 2020 UTC