php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76985 Compatibility on Redhat 6.7
Submitted: 2018-10-09 13:25 UTC Modified: 2018-10-10 16:13 UTC
From: selva dot rajulu at gmail dot com Assigned:
Status: Not a bug Package: PHP Language Specification
PHP Version: 7.1.22 OS: Redhat 6.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: selva dot rajulu at gmail dot com
New email:
PHP Version: OS:

 

 [2018-10-09 13:25 UTC] selva dot rajulu at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/faq
---
Hi Team,

Is there any OS related specification for PHP 7.1.X.?

I am trying to install PHP 7.1.22 on Redhat Linux 6.7, I would like to know whether PHP 7.1 is compatible with Redhat 6.7 server.?

Regards,
Selva


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-09 16:41 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-10-09 16:41 UTC] requinix@php.net
RHEL 6 supports PHP 5.3.

If you want PHP 7.1 then find a repo with it that you can add and install from.
If there isn't one then you'll need to build from sources.
 [2018-10-10 05:44 UTC] selva dot rajulu at gmail dot com
Thanks for your support.

Yes, by default Redhat 6 Supports PHP 5.3, now am compiling PHP 7.1 Source downloaded from http://php.net/get/php-7.1.22.tar.gz/from/a/mirror.

I want to confirm that, is there any OS dependent specification for PHP71 or we can install anywhere by compiling the Source file.
 [2018-10-10 16:13 UTC] requinix@php.net
PHP won't complain because you're using RHEL 6, but it will complain if you're unable to meet functional and dependency requirements.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 03:03:36 2021 UTC