php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76960 mb_strtoupper case mapping for ß is not correct
Submitted: 2018-10-02 14:12 UTC Modified: 2018-10-02 14:15 UTC
From: fundaris at gmail dot com Assigned: cmb (profile)
Status: Duplicate Package: mbstring related
PHP Version: 7.3.0RC2 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fundaris at gmail dot com
New email:
PHP Version: OS:

 

 [2018-10-02 14:12 UTC] fundaris at gmail dot com
Description:
------------
I don't know if this is related/the real bug.
https://bugs.php.net/bug.php?id=70072

After reading this https://github.com/php/php-src/blob/php-7.3.0RC2/UPGRADING

I noticed that example
mb_strtoupper("Straße")
// Produces STRAßE on PHP 7.2
// Produces STRASSE on PHP 7.3

But why are we doing this? There is an https://www.fileformat.info/info/unicode/char/1e9e/index.htm in UTF-8 spec and there for no need for a casing mapping!

Expected result:
----------------
mb_strtoupper("Straße")

should give a STRAßE with an LATIN CAPITAL LETTER SHARP S

Actual result:
--------------
STRAßE with an LATIN SMALL LETTER SHARP S

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-10-02 14:15 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2018-10-02 14:15 UTC] cmb@php.net
Duplicate of bug #76696.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Nov 15 03:01:25 2018 UTC