php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76888 PHP Startup: Unable to load dynamic library 'php_curl.dll'
Submitted: 2018-09-16 13:33 UTC Modified: 2018-10-06 14:52 UTC
From: masterwto at 163 dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 7.3.0RC1 OS: Windows 7 64bit
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: masterwto at 163 dot com
New email:
PHP Version: OS:

 

 [2018-09-16 13:33 UTC] masterwto at 163 dot com
Description:
------------
My Apache24 httpd.conf:

LoadModule php7_module "D:/Program Files/PHP7/php7apache2_4.dll"
PHPIniDir "D:/Program Files/PHP7"

My PHP7.3 php.ini:

; On windows:
extension_dir = "D:/Program Files/PHP7/ext"
extension=php_curl.dll

When Apache2.4 Windows service is started, I got the error:

PHP Warning:  PHP Startup: Unable to load dynamic library 'php_curl.dll' (tried: D:/Program Files/PHP7/ext\\php_curl.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3), D:/Program Files/PHP7/ext\\php_php_curl.dll.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3)) in Unknown on line 0
[Sun Sep 16 20:59:25.428390 2018] [mpm_winnt:notice] [pid 2992:tid 508] AH00455: Apache/2.4.34 (Win64) PHP/7.3.0RC1 configured -- resuming normal operations
[Sun Sep 16 20:59:25.428390 2018] [mpm_winnt:notice] [pid 2992:tid 508] AH00456: Apache Lounge VC15 Server built: Aug 15 2018 11:38:51
[Sun Sep 16 20:59:25.428390 2018] [core:notice] [pid 2992:tid 508] AH00094: Command line: 'D:\\Program Files\\Apache24\\bin\\httpd.exe -d D:/Program Files/Apache24'
[Sun Sep 16 20:59:25.428390 2018] [mpm_winnt:notice] [pid 2992:tid 508] AH00418: Parent: Created child process 6548
PHP Warning:  PHP Startup: Unable to load dynamic library 'php_curl.dll' (tried: D:/Program Files/PHP7/ext\\php_curl.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3), D:/Program Files/PHP7/ext\\php_php_curl.dll.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3)) in Unknown on line 0
[Sun Sep 16 20:59:26.364392 2018] [mpm_winnt:notice] [pid 6548:tid 456] AH00354: Child: Starting 64 worker threads.


When I changed the php.ini file to:

extension=curl

I got error like this:

PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: D:/Program Files/PHP7/ext\\curl (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3), D:/Program Files/PHP7/ext\\php_curl.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3)) in Unknown on line 0
[Sun Sep 16 21:31:27.302425 2018] [mpm_winnt:notice] [pid 6800:tid 508] AH00455: Apache/2.4.34 (Win64) PHP/7.3.0RC1 configured -- resuming normal operations
[Sun Sep 16 21:31:27.302425 2018] [mpm_winnt:notice] [pid 6800:tid 508] AH00456: Apache Lounge VC15 Server built: Aug 15 2018 11:38:51
[Sun Sep 16 21:31:27.302425 2018] [core:notice] [pid 6800:tid 508] AH00094: Command line: 'D:\\Program Files\\Apache24\\bin\\httpd.exe -d D:/Program Files/Apache24'
[Sun Sep 16 21:31:27.302425 2018] [mpm_winnt:notice] [pid 6800:tid 508] AH00418: Parent: Created child process 2524
PHP Warning:  PHP Startup: Unable to load dynamic library 'curl' (tried: D:/Program Files/PHP7/ext\\curl (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3), D:/Program Files/PHP7/ext\\php_curl.dll (\xef\xbf\xbd\xd2\xb2\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xd6\xb8\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xef\xbf\xbd\xc4\xa3\xef\xbf\xbd\xe9\xa1\xa3)) in Unknown on line 0
[Sun Sep 16 21:31:27.879626 2018] [mpm_winnt:notice] [pid 2524:tid 456] AH00354: Child: Starting 64 worker threads.


Test script:
---------------
no need php file at all.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-17 08:54 UTC] ab@php.net
-Status: Open +Status: Not a bug
 [2018-09-17 08:54 UTC] ab@php.net
Thanks for the report. The curl extension has several dependency DLL which are contained in the PHP ditribution. Please ensure the PHP root dir is on the path, when the PHP module is being loaded into Apache.

Note, the DBCS encoded error messages are a separate topic.

Thanks.
 [2018-09-17 13:17 UTC] masterwto at 163 dot com
1. The PHP7.3 root directory is on my PATH environment.
2. The PHP module is loaded into Apache, and PHP scripts can be executed correctly (no cURL functions).
3. PHP 7.1 & 7.2 is working OK.

What dependency DLLs contained in the PHP ditribution is used by cURL?
Do I need to copy those files to Apache\bin dir?
 [2018-10-06 14:47 UTC] pmmaga@php.net
Automatic comment on behalf of mail@pmmaga.net
Revision: http://git.php.net/?p=php-src.git;a=commit;h=82e10f3974fe0da51e3ed482e8ecdb4ecd7219d0
Log: Fix #76888 - Remove unstable test
 [2018-10-06 14:47 UTC] pmmaga@php.net
-Status: Not a bug +Status: Closed
 [2018-10-06 14:52 UTC] nikic@php.net
-Status: Closed +Status: Not a bug
 [2018-10-06 14:52 UTC] nikic@php.net
Reverting spurious change due to incorrect bug ID referenced in commit message.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 07:01:34 2019 UTC