php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76858 Php compile error
Submitted: 2018-09-10 17:19 UTC Modified: 2018-09-10 18:06 UTC
From: ben at hakim dot co dot il Assigned: cmb (profile)
Status: Duplicate Package: MySQLi related
PHP Version: 7.2.9 OS: Centos 7.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ben at hakim dot co dot il
New email:
PHP Version: OS:

 

 [2018-09-10 17:19 UTC] ben at hakim dot co dot il
Description:
------------
configure :


./configure \
 "--prefix=/etc/php" \
 "--exec-prefix=/etc/php" \
 "--sysconfdir=/etc/php/conf" \
 "--bindir=/usr/bin" \
 "--sbindir=/usr/sbin" \
 "--includedir=/usr/include" \
 "--libexecdir=/usr/lib/php" \
 "--localstatedir=/var" \
 "--libdir=/usr/lib/php" \
 "--mandir=/usr/share/man" \
 "--with-config-file-scan-dir=/etc/php/conf/php-fpm.d" \
 "--with-mysqli=mysqlnd" \
 "--with-pcre-regex" \
 "--with-mysql-sock=/var/lib/mysql/mysql.sock" \
 "--with-mysqli=mysqlnd" \
 "--with-pdo-mysql=mysqlnd" \
 "--with-fpm-user=webserver" \
 "--with-fpm-group=webserver" \
 "--with-fpm-systemd" \
 "--enable-fpm" \
 "--enable-json" \
 "--enable-calendar" \
 "--enable-pdo" \
 "--enable-phar" \
 "--enable-session" \
 "--enable-mbstring" \
 "--disable-cgi" \
 "--disable-phpdbg" \
 "--disable-all"




Expected result:
----------------
installation without an error

Actual result:
--------------
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:885: undefined reference to `PHP_SHA256Init'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:886: undefined reference to `PHP_SHA256Update'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:887: undefined reference to `PHP_SHA256Final'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:890: undefined reference to `PHP_SHA256Init'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:891: undefined reference to `PHP_SHA256Update'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:892: undefined reference to `PHP_SHA256Final'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:895: undefined reference to `PHP_SHA256Init'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:896: undefined reference to `PHP_SHA256Update'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:897: undefined reference to `PHP_SHA256Update'
/usr/local/binary/build/php-7.2.9/ext/mysqlnd/mysqlnd_auth.c:898: undefined reference to `PHP_SHA256Final'
collect2: error: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-10 17:21 UTC] ben at hakim dot co dot il
After configure try to do "make"
and it's failed.
 [2018-09-10 17:28 UTC] spam2 at rhsoft dot net
--disable-all

what about not exclude the ash extension and try to *start* with "--disable-all" instead finish with it which in my understanding would win against every --enable above
 [2018-09-10 17:33 UTC] ben at hakim dot co dot il
yea.
when I do "--enable-hash" it's working.

I think the error must should be change or something.
 [2018-09-10 17:38 UTC] spam2 at rhsoft dot net
no, if you sue tihings like --disable-all you are supposed to know what you are doing
 [2018-09-10 18:06 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Package: MySQL related +Package: MySQLi related -Assigned To: +Assigned To: cmb
 [2018-09-10 18:06 UTC] cmb@php.net
Duplicate of bug #76600.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 02:03:34 2021 UTC