php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76854 streamWrapper behaves differently
Submitted: 2018-09-10 07:18 UTC Modified: 2018-09-10 09:03 UTC
From: miloslav dot hula at gmail dot com Assigned:
Status: Duplicate Package: Streams related
PHP Version: 7.3.0beta3 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: miloslav dot hula at gmail dot com
New email:
PHP Version: OS:

 

 [2018-09-10 07:18 UTC] miloslav dot hula at gmail dot com
Description:
------------
Nette Tester (https://github.com/nette/tester) uses streamWrapper to mock files. On PHP 7.2.8 all tests pass, on 7.3.0beta3 one behaves differently. Probably when truncating file contents.

Following code is extraction from Tester.

Test script:
---------------
https://gist.github.com/milo/c13fe314c486451d2c545b923e73622f


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-09-10 08:32 UTC] requinix@php.net
-Status: Open +Status: Duplicate
 [2018-09-10 08:32 UTC] requinix@php.net
Duplicate of bug #76803, which has been fixed.
 [2018-09-10 08:50 UTC] miloslav dot hula at gmail dot com
-Status: Duplicate +Status: Closed
 [2018-09-10 08:50 UTC] miloslav dot hula at gmail dot com
Thank you.
 [2018-09-10 08:50 UTC] requinix@php.net
-Status: Closed +Status: Duplicate
 [2018-09-10 08:58 UTC] miloslav dot hula at gmail dot com
Not sure why you reopened the issue, but I'm sure that David Grudl, creator of #76803, has the same "bug source". He only isolated it better. From my point of view it can be closed.
 [2018-09-10 09:03 UTC] requinix@php.net
Duplicate is neither open nor closed. It means the issue is being (or, like here, has already been) addressed by another report.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 13:01:26 2018 UTC