php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76759 The removal of the split() function is missing in the php 7 migration docs
Submitted: 2018-08-17 13:21 UTC Modified: 2018-08-17 14:26 UTC
From: p dot dudink at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 7.0.31 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: p dot dudink at gmail dot com
New email:
PHP Version: OS:

 

 [2018-08-17 13:21 UTC] p dot dudink at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/migration70.incompatible
---

While migrating from PHP 5.6 to PHP 7.1 I just came across the fact that function split() is removed.
However the migration docs do not mention that:
http://www.php.net/migration70.incompatible

The split()-documentation does:
http://php.net/manual/en/function.split.php

This should be added on the mentioned migration page.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-08-17 14:26 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-08-17 14:26 UTC] cmb@php.net
The migration guide already mentions the removal of the ereg extension[1].

[1] <http://php.net/manual/en/migration70.removed-exts-sapis.php>
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 19 16:01:24 2020 UTC