php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76652 Tests
Submitted: 2018-07-22 21:06 UTC Modified: 2018-07-22 21:25 UTC
From: celestinoxp at hotmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Testing related
PHP Version: 7.2.8 OS: Windows 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: celestinoxp at hotmail dot com
New email:
PHP Version: OS:

 

 [2018-07-22 21:06 UTC] celestinoxp at hotmail dot com
Description:
------------
When try run tests have an error

Test script:
---------------
C:\xampp\php>php tests/Alltests.php

Expected result:
----------------
Test Results

Actual result:
--------------
Parse error: syntax error, unexpected 'new' (T_NEW) in C:\xampp\php\pear\Event\Dispatcher.php on line 249

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-22 21:10 UTC] spam2 at rhsoft dot net
why don't you report that to xampp so the fix their code?
frankly you even don't provide the source line in question here
 [2018-07-22 21:12 UTC] daverandom@php.net
-Status: Open +Status: Feedback
 [2018-07-22 21:12 UTC] daverandom@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2018-07-22 21:25 UTC] cmb@php.net
-Status: Feedback +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2018-07-22 21:25 UTC] cmb@php.net
This is not a PHP issue, but rather a bug in the PEAR
Event_Dispatcher package, and therefore should be filed in the
PEAR bug tracker[1].  The reported line[2] doesn't appear quite
suitable for PHP 7.

[1] <https://pear.php.net/bugs/report.php?package=Event_Dispatcher>
[2] <http://svn.php.net/viewvc/pear/packages/Event_Dispatcher/trunk/Event/Dispatcher.php?view=markup#l249>
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC