php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76614 MYSQL_ATTTR_* definitions define all values as "integer"
Submitted: 2018-07-12 04:20 UTC Modified: 2018-07-12 04:51 UTC
From: rgagnon24 at gmail dot com Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 7.1.19 OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rgagnon24 at gmail dot com
New email:
PHP Version: OS:

 

 [2018-07-12 04:20 UTC] rgagnon24 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/ref.pdo-mysql
---

Each PDO Attribute is a different type, but the documentation shows all of them as integer.

For example:  MYSQL_ATTR_SSL_CA accepts a string but the documentation shows MYSQL_ATTR_SSL_CA(integer)

Some accept strings, some integers, some boolean.

Test script:
---------------
// No test script needed.  Doc problem


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-12 04:51 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-07-12 04:51 UTC] requinix@php.net
They *are* all integers.

You're confusing the the value of the constant with the way the constant is used.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 18:34:40 2020 UTC