php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76603 PhpMyAdmin error!
Submitted: 2018-07-10 09:24 UTC Modified: 2018-07-10 09:30 UTC
From: celestinoxp at hotmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.3Git-2018-07-10 (snap) OS: Windows 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: celestinoxp at hotmail dot com
New email:
PHP Version: OS:

 

 [2018-07-10 09:24 UTC] celestinoxp at hotmail dot com
Description:
------------
When update from php 7.3 alpha 3 to php7.3 snapshot (Revision: r6c61f15 (July 10 2018, 03:00:20)), phpmyadmin shows various errors.

Warning in .\libraries\classes\Config\FormDisplay.php#658
 "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Backtrace

.\vendor\composer\ClassLoader.php#444: include()
.\vendor\composer\ClassLoader.php#322: Composer\Autoload\includeFile(string 'C:\\xampp\\phpMyAdmin\\vendor\\composer/../../libraries/classes\\Config\\FormDisplay.php')
Composer\Autoload\ClassLoader->loadClass(string 'PhpMyAdmin\\Config\\FormDisplay')
.\libraries\classes\Config\Forms\BaseForm.php#16: spl_autoload_call(string 'PhpMyAdmin\\Config\\FormDisplay')
.\vendor\composer\ClassLoader.php#444: include(.\libraries\classes\Config\Forms\BaseForm.php)
.\vendor\composer\ClassLoader.php#322: Composer\Autoload\includeFile(string 'C:\\xampp\\phpMyAdmin\\vendor\\composer/../../libraries/classes\\Config\\Forms\\BaseForm.php')
Composer\Autoload\ClassLoader->loadClass(string 'PhpMyAdmin\\Config\\Forms\\BaseForm')
.\libraries\classes\Config\Forms\User\FeaturesForm.php#12: spl_autoload_call(string 'PhpMyAdmin\\Config\\Forms\\BaseForm')
.\vendor\composer\ClassLoader.php#444: include(.\libraries\classes\Config\Forms\User\FeaturesForm.php)
.\vendor\composer\ClassLoader.php#322: Composer\Autoload\includeFile(string 'C:\\xampp\\phpMyAdmin\\vendor\\composer/../../libraries/classes\\Config\\Forms\\User\\FeaturesForm.php')
Composer\Autoload\ClassLoader->loadClass(string 'PhpMyAdmin\\Config\\Forms\\User\\FeaturesForm')
.\libraries\classes\Config\Forms\BaseFormList.php#123: spl_autoload_call(string 'PhpMyAdmin\\Config\\Forms\\User\\FeaturesForm')
.\libraries\classes\UserPreferences.php#181: PhpMyAdmin\Config\Forms\BaseFormList::getFields()
.\libraries\classes\Config.php#885: PhpMyAdmin\UserPreferences->apply(array)
.\libraries\common.inc.php#453: PhpMyAdmin\Config->loadUserPreferences()
.\index.php#26: require_once(.\libraries\common.inc.php)

I reported this error to PhpMyAdmin, but my version of php is a snapshot.
Question: Problem is with PHP or PhpMyAdmin??


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-10 09:30 UTC] requinix@php.net
-Status: Open +Status: Not a bug
 [2018-07-10 09:30 UTC] requinix@php.net
phpMyAdmin does not support 7.3 yet.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Sep 18 09:01:27 2019 UTC