php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #76593 No way to get error messages with clickable link.
Submitted: 2018-07-07 19:30 UTC Modified: 2018-07-07 21:04 UTC
From: svin83 at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 7.2.7 OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: svin83 at gmail dot com
New email:
PHP Version: OS:

 

 [2018-07-07 19:30 UTC] svin83 at gmail dot com
Description:
------------
vars from my loaded ini file:

html_errors = On
docref_root = "http://localhost/phpmanual/"
docref_ext = .html
error_log = php_errors.log
report_memleaks = On
ignore_repeated_source = Off
ignore_repeated_errors = Off
log_errors = On
display_startup_errors = On
display_errors = On
error_reporting = E_ALL

I downloaded the complete manual (zip) and extracted it to /phpmanual/ in document root, so the url in docref_root works in any browser.

Even something as simple as trying to echo an array, or omitting the semicolon a few times will be great examples of no link showing up.

---
From manual page: http://www.php.net/errorfunc.configuration
---


Test script:
---------------
<?php
$page=['<!DOCTYPE html>','<html>','<head>','<title>Test</title>','</head>','<body>','<h1>Test</h1>','</body>','</html>'];
echo $page;
?>

Expected result:
----------------
A link to error-related info in the manual... As promised...

Actual result:
--------------
No link here...

<br />
<b>Notice</b>:  Array to string conversion in <b>/srv/http/example/index.php</b> on line <b>3</b><br />
Array


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-07-07 21:04 UTC] requinix@php.net
-Status: Open +Status: Not a bug -Package: Documentation problem +Package: *General Issues
 [2018-07-07 21:04 UTC] requinix@php.net
Not every possible error has a link. In fact it's mostly for functions.

<?php
echo implode("string");
?>
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 13:01:26 2018 UTC