php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #76504 FTBFS with ICU 59+ and GCC 8
Submitted: 2018-06-20 13:14 UTC Modified: 2018-06-21 07:42 UTC
From: bugs dot php dot net at majkl578 dot cz Assigned: ab (profile)
Status: Closed Package: Compile Failure
PHP Version: 7.3Git-2018-06-20 (Git) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugs dot php dot net at majkl578 dot cz
New email:
PHP Version: OS:

 

 [2018-06-20 13:14 UTC] bugs dot php dot net at majkl578 dot cz
Description:
------------
Compilation of ext-intl fails with libicu 59+ and GCC 8.

Caused by https://github.com/php/php-src/commit/5dd1ef90caec3021e6ce55c8554e695edf641eaf.

Test script:
---------------
Dockerfile:
====================
FROM debian:experimental

RUN apt-get update && apt-get install -y --no-install-recommends make autoconf gcc-8 g++-8 libicu-dev bison ca-certificates curl
RUN mkdir /php && cd /php
RUN curl -Lq https://github.com/php/php-src/archive/5dd1ef90caec3021e6ce55c8554e695edf641eaf.tar.gz | tar -xzf - --strip-components=1
RUN ./buildconf && CC=gcc-8 CXX=g++-8 ./configure --disable-all --enable-intl && make
====================

run as:
docker build -t php - < Dockerfile

Expected result:
----------------
no error

Actual result:
--------------
/bin/bash //libtool --silent --preserve-dup-deps --mode=compile g++-8 -I/usr/include  -Wno-write-strings -D__STDC_LIMIT_MACROS -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -std=c++11  -DU_USING_ICU_NAMESPACE=1 -std=c++11 -stdlib=libc++ -Iext/intl/ -I//ext/intl/ -DPHP_ATOM_INC -I//include -I//main -I/ -I/ext/date/lib -I//ext/date/lib -I//TSRM -I//Zend    -g -O2  -c //ext/intl/intl_convertcpp.cpp -o ext/intl/intl_convertcpp.lo 
g++-8: error: unrecognized command line option '-stdlib=libc++'
make: *** [Makefile:632: ext/intl/intl_convertcpp.lo] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2018-06-21 07:42 UTC] ab@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ab
 [2018-06-21 07:42 UTC] ab@php.net
This patch was reverted in all dev branches, thus consider it resolved.

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 10 18:01:24 2021 UTC